Problem with Voice Commands
Grab our Forum Feed

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: Problem with Voice Commands

  1. #1
    Join Date
    Aug 2016
    Location
    St. Louis, MO
    Posts
    2

    Default Problem with Voice Commands

    I was having trouble with the voice commands on my 2017 Premier. The dealer told me it was probably a phone issue but when I took the car in the Volt Tech had the same issue with his phone once it was paired. He had no idea what was causing it so he call GM Tech support. It seems that Volts get what he called a "logic lock" and the voice commands stop working. What needs to be done to fix the issue it to go into settings, change the language to Spanish (not sure if other languages will work) then shut down the car for 5 minutes. Go back into the system and change the language back to English and the voice commands will work fine.

    I'm not sure why this works but it dose and I haven't had any problem since.

    I hope this helps.

  2. #2
    Join Date
    Aug 2009
    Location
    Texas - DFW
    Posts
    4,433

    Default

    So, the language is not set from the factory? Seems kind of a wacko fix, but, I've seen worse before in other software.
    Driving a show car. Every day! Hidden Content


    ------------------------
    2014 Crystal Red ELR (REDD) code R w/Cashmere interior
    L2 - GE WattStation
    iOS 10.3 on iPhone 6. MyCadillac App version 3.5.0
    Hidden Content
    Hidden Content

  3. #3
    Join Date
    Jun 2012
    Location
    Deerfield Beach, FL
    Posts
    436

    Default

    Quote Originally Posted by RLDahle View Post
    I was having trouble with the voice commands on my 2017 Premier. The dealer told me it was probably a phone issue but when I took the car in the Volt Tech had the same issue with his phone once it was paired. He had no idea what was causing it so he call GM Tech support. It seems that Volts get what he called a "logic lock" and the voice commands stop working. What needs to be done to fix the issue it to go into settings, change the language to Spanish (not sure if other languages will work) then shut down the car for 5 minutes. Go back into the system and change the language back to English and the voice commands will work fine.

    I'm not sure why this works but it dose and I haven't had any problem since.

    I hope this helps.
    I had the exact same issue on my 2017 Premier. Left the car at the dealer for a week while I went on vacation and when I got back, the dealer told me of the same "fix". It has worked fine ever since.
    "Faraday2" | 2017 Citron Green Metallic with Jet Black Leather. MyLink with Navigation & Bose, Driver Confidence Packages 1 & 2, Premium Trim, Delivered on 04/23/2016!

  4. Remove Advertisements
    GM-Volt.com
    Advertisements

  5. Advertisement

  6. #4
    Join Date
    Apr 2016
    Location
    Northeast USA
    Posts
    105

    Default

    My 2011 Dodge Journey has an interesting bug where the software in the radio amplifier locks up causing the car to lose all internal sounds, beeps, audio, etc... The fix is to either disconnect the battery or pull the power plug from the amp and then reconnect which reboots the software.

    Gotta love modern cars and the bugs that come along with them.

  7. #5
    Join Date
    Aug 2016
    Location
    Outer Banks, NC
    Posts
    52

    Default

    My 2017 Volt Premier doesn't hear me say "Yes"! I push the voice button and say "Call Joe Smith Mobile". My Car says: "If you want to call Joe Smith Mobile, say Yes". I say "Yes". Car says it didn't hear me. Of course I'm yelling "Yes Yes Yes". Car ends up saying "I haven't received a response, goodbye". (Or whatever it says)

    Why won't my car hear me say "Yes"?
    "Glasspilot"
    Andy
    2017 Volt
    1999 Chevy Monte Carlo

  8. #6
    Join Date
    Feb 2016
    Location
    Troy, NY
    Posts
    311

    Default

    Quote Originally Posted by glasspilot View Post
    My 2017 Volt Premier doesn't hear me say "Yes"! I push the voice button and say "Call Joe Smith Mobile". My Car says: "If you want to call Joe Smith Mobile, say Yes". I say "Yes". Car says it didn't hear me. Of course I'm yelling "Yes Yes Yes". Car ends up saying "I haven't received a response, goodbye". (Or whatever it says)

    Why won't my car hear me say "Yes"?
    Have you tried the fix described above?
    2016 Irridescent Pearl LT / Black Leather

  9. #7
    Join Date
    Aug 2016
    Location
    Outer Banks, NC
    Posts
    52

    Default

    I finally got around to doing the fix in the OP. Haven't put it back to English yet. I'll report back with the results later.
    "Glasspilot"
    Andy
    2017 Volt
    1999 Chevy Monte Carlo

  10. #8
    Join Date
    Mar 2015
    Location
    NW San Fernando Valley, CA
    Posts
    449

    Default

    My problem is that the voice recognition in the car is simply mediocre at best. When I say, "Call XXX on the mobile", for example, it will often pick the wrong name... Android Auto, on the other hand, has never made a mistake.
    2017 Heather Grey Premier with all options except ACC and Ambient. Leased 3/5/2016 to replace my leased 2011 Leaf SL-e. 20,000 miles as of 03/15/2017. Tesla Model 3 reserved.

  11. #9
    Join Date
    Jun 2015
    Location
    Sacramento Area, CA
    Posts
    942

    Default

    Quote Originally Posted by Tomt View Post
    My problem is that the voice recognition in the car is simply mediocre at best. When I say, "Call XXX on the mobile", for example, it will often pick the wrong name... Android Auto, on the other hand, has never made a mistake.
    That has alos been my observation as well. MyLink is ok, AA is great.
    Hidden Content - BLK interior - Driver 1& 2 confidence pkg - Hidden Content
    L2 Charger - Hidden Content - Hidden Content
    Hidden Content

  12. Advertisement

  13. #10
    Join Date
    Aug 2016
    Location
    Outer Banks, NC
    Posts
    52

    Default

    >>>I'll report back with the results later. <<<

    Nope. I reinstated English. Tried to make a call. It understands everything I say until it asks for "Yes". I say it 20 times and it says "I have heard no response, good bye".
    "Glasspilot"
    Andy
    2017 Volt
    1999 Chevy Monte Carlo

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Quick Reply Quick Reply

  • Decrease Size
    Increase Size
  • Remove Text Formatting
  • Insert LinkInsert ImageInsert Video
  • Wrap [QUOTE] tags around selected text

Similar Threads

  1. Odd new problem with Voice Commands for Sirius/XM
    By gadgeTT in forum Generation 2 Volt (2016-2020)
    Replies: 0
    Last Post: 07-07-2016, 05:50 PM
  2. What voice commands do you use most?
    By CraigCa in forum Generation 1 Volt (2011-2015)
    Replies: 22
    Last Post: 07-03-2014, 05:21 PM
  3. These are a few of my favorite voice commands
    By bradstone in forum Generation 1 Volt (2011-2015)
    Replies: 11
    Last Post: 12-12-2013, 09:34 PM
  4. Handsfree Voice Access to Phone's Voice Commands via Bluetooth?
    By gadgeTT in forum Generation 1 Volt (2011-2015)
    Replies: 5
    Last Post: 08-24-2012, 12:17 AM
  5. 2012 Volt voice commands
    By Blastphemy in forum Newcomers to GM-VOLT.COM (See here for FAQs)
    Replies: 10
    Last Post: 08-06-2012, 04:32 PM

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts